aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-26 22:30:44 -0500
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-26 22:30:44 -0500
commitbab27b91609d93dc5d6ed6dd2b3fadefcf7f3d90 (patch)
treeef07607f10c7487a1cee1a49728332ed382e2984 /debian
parent97eb2fd0abb21d25a80882a06b8853d682e7c42e (diff)
downloadlibayatana-appindicator-bab27b91609d93dc5d6ed6dd2b3fadefcf7f3d90.tar.gz
libayatana-appindicator-bab27b91609d93dc5d6ed6dd2b3fadefcf7f3d90.tar.bz2
libayatana-appindicator-bab27b91609d93dc5d6ed6dd2b3fadefcf7f3d90.zip
Override dh_auto_test to run tests per-flavor.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules12
2 files changed, 13 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d80fdd2..29e1060 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ libappindicator (12.10.1-0ubuntu1) UNRELEASED; urgency=low
- Convert from cdbs to debhelper 9.
- Add and export DPKG_GENSYMBOLS_CHECK_LEVEL.
- Override dh_autoreconf to run autogen.sh and not call configure.
+ - Override dh_auto_test to run tests per-flavor.
* debian/*.install:
- Update paths for multiarch and for use with dh9 (remove debian/tmp...)
diff --git a/debian/rules b/debian/rules
index 76b3c11..c12b9bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,6 +65,18 @@ override_dh_install:
dh_install -plibappindicator0.1-cil --fail-missing --sourcedir=debian/tmp/gtk2
dh_install -plibappindicator0.1-cil-dev --fail-missing --sourcedir=debian/tmp/gtk2
+override_dh_auto_test: $(FLAVORS:%=dotest-%)
+
+dotest-%:
+ dh_auto_test --builddirectory=build/$*
+
+dotest-gtk2: $(PY_VERSIONS:%=dotestgtk2-%)
+ # GTK2 flavor test was run on a per-python-version basis.
+
+dotestgtk2-%:
+ PYTHON=`which $*` \
+ dh_auto_test --builddirectory=build/gtk2
+
override_dh_auto_clean:
dh_auto_clean
rm -rf build