aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-02 09:58:36 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-02 09:58:36 +0100
commit4f9c4e93f3a7808cc838cba4cdb460d66d315786 (patch)
treed9a654fd20e9e75935c450b115076099eb99b857 /example/CMakeLists.txt
parentf225dccbd82f48bb1ab10767b9b074e24fedb0f3 (diff)
parent694ab4eec294a93358f78a349c6df94c3b666126 (diff)
downloadlibayatana-appindicator-4f9c4e93f3a7808cc838cba4cdb460d66d315786.tar.gz
libayatana-appindicator-4f9c4e93f3a7808cc838cba4cdb460d66d315786.tar.bz2
libayatana-appindicator-4f9c4e93f3a7808cc838cba4cdb460d66d315786.zip
Merge branch 'tari01-pr/fix-build-warnings'
Attributes GH PR #59: https://github.com/AyatanaIndicators/libayatana-appindicator/pull/59
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
index a337cdc..0b5f133 100644
--- a/example/CMakeLists.txt
+++ b/example/CMakeLists.txt
@@ -31,7 +31,7 @@ if (FLAVOUR_GTK3)
# simple-client-vala
- set_source_files_properties("${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c" PROPERTIES COMPILE_FLAGS " -include ${CMAKE_SOURCE_DIR}/src/app-indicator.h")
+ set_source_files_properties("${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c" PROPERTIES COMPILE_FLAGS " -include ${CMAKE_SOURCE_DIR}/src/app-indicator.h -Wno-incompatible-pointer-types -Wno-unused-but-set-variable")
add_executable("simple-client-vala" "${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c")
target_include_directories("simple-client-vala" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})
target_link_libraries("simple-client-vala" "${PROJECT_DEPS_LIBRARIES} -l${ayatana_appindicator_gtkver} -L${CMAKE_BINARY_DIR}/src")