aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-02-11 14:06:49 +0100
committerRobert Tari <robert@tari.in>2022-02-11 14:06:49 +0100
commite6b34ef4daa0809c7bfd5cbffc7cbcc1d053345b (patch)
treeefe674547e63cbf829b51eef92d6c4d1644d426d /example/CMakeLists.txt
parent3bec2d1519b31791d0c098e4ab2d6ae9d693ab53 (diff)
downloadlibayatana-appindicator-e6b34ef4daa0809c7bfd5cbffc7cbcc1d053345b.tar.gz
libayatana-appindicator-e6b34ef4daa0809c7bfd5cbffc7cbcc1d053345b.tar.bz2
libayatana-appindicator-e6b34ef4daa0809c7bfd5cbffc7cbcc1d053345b.zip
Clean up compilation flags
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
index 3a6cd53..a337cdc 100644
--- a/example/CMakeLists.txt
+++ b/example/CMakeLists.txt
@@ -31,7 +31,7 @@ if (FLAVOUR_GTK3)
# simple-client-vala
- set_source_files_properties("${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c" PROPERTIES COMPILE_FLAGS "${COMPILE_FLAGS} -include ${CMAKE_SOURCE_DIR}/src/app-indicator.h")
+ set_source_files_properties("${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c" PROPERTIES COMPILE_FLAGS " -include ${CMAKE_SOURCE_DIR}/src/app-indicator.h")
add_executable("simple-client-vala" "${CMAKE_CURRENT_BINARY_DIR}/simple-client-vala.c")
target_include_directories("simple-client-vala" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})
target_link_libraries("simple-client-vala" "${PROJECT_DEPS_LIBRARIES} -l${ayatana_appindicator_gtkver} -L${CMAKE_BINARY_DIR}/src")
@@ -41,7 +41,6 @@ endif()
# simple-client
-set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/simple-client.c" PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
add_executable("simple-client" "${CMAKE_CURRENT_SOURCE_DIR}/simple-client.c")
target_compile_definitions("simple-client" PUBLIC LOCAL_ICON="${CMAKE_CURRENT_SOURCE_DIR}/simple-client-test-icon.png")
target_include_directories("simple-client" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})