aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-06 16:38:29 -0600
committerTed Gould <ted@gould.cx>2010-12-06 16:38:29 -0600
commit07aeca3802b2e19878b24637f1f73d971c7be101 (patch)
tree545dc7b2fbf60bc9187d8b609914d40ec815be3d /src/Makefile.am
parenta92f87080dea6c0d16bfb55bf75e155658bfa372 (diff)
downloadlibayatana-appindicator-07aeca3802b2e19878b24637f1f73d971c7be101.tar.gz
libayatana-appindicator-07aeca3802b2e19878b24637f1f73d971c7be101.tar.bz2
libayatana-appindicator-07aeca3802b2e19878b24637f1f73d971c7be101.zip
Switching the names of the generated files to stop automake from thinking it needs to build the XML files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 16 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 673938b..5b6adc2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -62,10 +62,10 @@ libappindicator_la_SOURCES = \
dbus-shared.h \
generate-id.h \
generate-id.c \
- notification-item.xml.h \
- notification-item.xml.c \
- notification-watcher.xml.h \
- notification-watcher.xml.c
+ gen-notification-item.xml.h \
+ gen-notification-item.xml.c \
+ gen-notification-watcher.xml.h \
+ gen-notification-watcher.xml.c
libappindicator_la_LDFLAGS = \
-version-info 1:0:0 \
@@ -99,25 +99,27 @@ DBUS_SPECS = \
notification-item.xml \
notification-watcher.xml
-%.xml.h: %.xml
+gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
+ @echo "extern const char * $(subst -,_,$(subst .,_,$(basename $<)));" > $@
-%.xml.c: %.xml
+gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ @echo "const char * $(subst -,_,$(subst .,_,$(basename $<))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@
BUILT_SOURCES += \
- notification-item.xml.c \
- notification-item.xml.h \
- notification-watcher.xml.c \
- notification-watcher.xml.h
+ gen-notification-item.xml.c \
+ gen-notification-item.xml.h \
+ gen-notification-watcher.xml.c \
+ gen-notification-watcher.xml.h
CLEANFILES += \
- $(DBUS_SPECS:.xml=.xml.h) \
- $(DBUS_SPECS:.xml=.xml.c)
+ gen-notification-item.xml.c \
+ gen-notification-item.xml.h \
+ gen-notification-watcher.xml.c \
+ gen-notification-watcher.xml.h
EXTRA_DIST += $(DBUS_SPECS)