aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-06 09:50:21 -0600
committerTed Gould <ted@gould.cx>2010-12-06 09:50:21 -0600
commit2209cb8604a929a6f1af5cec4991388ad32a7d1c (patch)
treed5eed2a31ac650a54096b568244579cd19d73e2b /src/Makefile.am
parent4d2b723c0c6095e07cdbd908971edcfc37128920 (diff)
downloadlibayatana-appindicator-2209cb8604a929a6f1af5cec4991388ad32a7d1c.tar.gz
libayatana-appindicator-2209cb8604a929a6f1af5cec4991388ad32a7d1c.tar.bz2
libayatana-appindicator-2209cb8604a929a6f1af5cec4991388ad32a7d1c.zip
Changing to not use the dbus binding tool but to instead turn the XML files into pseudo-C
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 14 insertions, 22 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 073fc41..ce83951 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,10 +54,6 @@ libappindicatorinclude_HEADERS = \
$(libappindicator_headers) \
$(glib_enum_h)
-BUILT_SOURCES += \
- notification-watcher-client.h \
- notification-item-server.h
-
libappindicator_la_SOURCES = \
$(libappindicator_headers) \
app-indicator-enum-types.c \
@@ -65,7 +61,11 @@ libappindicator_la_SOURCES = \
application-service-marshal.c \
dbus-shared.h \
generate-id.h \
- generate-id.c
+ generate-id.c \
+ notification-item.xml.h \
+ notification-item.xml.c \
+ notification-watcher.xml.h \
+ notification-watcher.xml.c
libappindicator_la_LDFLAGS = \
-version-info 1:0:0 \
@@ -99,25 +99,17 @@ DBUS_SPECS = \
notification-item.xml \
notification-watcher.xml
-%-client.h: %.xml
- dbus-binding-tool \
- --prefix=_$(notdir $(subst -,_,$(<:.xml=)))_client \
- --mode=glib-client \
- --output=$@ \
- $<
-
-%-server.h: %.xml
- dbus-binding-tool \
- --prefix=_$(notdir $(subst -,_,$(<:.xml=)))_server \
- --mode=glib-server \
- --output=$@ \
- $<
+%.xml.h: %.xml
+ echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
-BUILT_SOURCES += \
- $(DBUS_SPECS:.xml=-client.h) \
- $(DBUS_SPECS:.xml=-server.h)
+%.xml.c: %.xml
+ echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
+ echo ";" >> $@
-CLEANFILES += $(BUILT_SOURCES)
+CLEANFILES += \
+ $(DBUS_SPECS:.xml=.xml.h) \
+ $(DBUS_SPECS:.xml=.xml.c)
EXTRA_DIST += $(DBUS_SPECS)