aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-08 11:00:54 -0600
committerTed Gould <ted@gould.cx>2010-12-08 11:00:54 -0600
commit41edd6b1dd171d887fe6bc860a1451358b630add (patch)
tree4b57a01d268833b2a7f609bb44d00643e63b5d87 /src/Makefile.am
parenta977f312789bec573e7256b50531f44bc8d45a85 (diff)
downloadlibayatana-appindicator-41edd6b1dd171d887fe6bc860a1451358b630add.tar.gz
libayatana-appindicator-41edd6b1dd171d887fe6bc860a1451358b630add.tar.bz2
libayatana-appindicator-41edd6b1dd171d887fe6bc860a1451358b630add.zip
Adding in some '_' so that the symbols don't get exported in the library.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5b6adc2..a5ea29b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -101,11 +101,11 @@ DBUS_SPECS = \
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * $(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * $(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@