aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-03 20:44:18 -0600
committerTed Gould <ted@gould.cx>2010-12-03 20:44:18 -0600
commitb90242a423f62ee594f2421b1147e317d9a4ab68 (patch)
treec679fbaf1cff03fe2e1840b58eedb3ba56f3abf6 /src/Makefile.am
parentd2a48b2530f5218ca71673ab072b707e374ad0c6 (diff)
parent63f47256a8dc38452d2ea62f7e846ecb44f6d30d (diff)
downloadlibayatana-appindicator-b90242a423f62ee594f2421b1147e317d9a4ab68.tar.gz
libayatana-appindicator-b90242a423f62ee594f2421b1147e317d9a4ab68.tar.bz2
libayatana-appindicator-b90242a423f62ee594f2421b1147e317d9a4ab68.zip
Updating to trunk so that we get the GI fixes
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dc81059..6f2990e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,9 @@
CLEANFILES =
DISTCLEANFILES =
BUILT_SOURCES =
-EXTRA_DIST = appindicator-0.1.pc.in
+EXTRA_DIST = \
+ appindicator-0.1.pc.in \
+ AppIndicator-0.1.metadata
include $(top_srcdir)/Makefile.am.enum
include $(top_srcdir)/Makefile.am.marshal
@@ -106,16 +108,17 @@ EXTRA_DIST += $(DBUS_SPECS)
INTROSPECTION_GIRS =
INTROSPECTION_SCANNER_ARGS = \
--add-include-path=$(srcdir) \
- $(addprefix --c-include=libappindicator/, $(introspection_sources))
+ $(addprefix --c-include=src/, $(introspection_sources)) \
+ --symbol-prefix=app \
+ --identifier-prefix=App
INTROSPECTION_COMPILER_ARGS = --includedir=$(builddir)
if HAVE_INTROSPECTION
introspection_sources = \
- $(addprefix $(srcdir)/,$(libappindicator_headers)) \
- $(addprefix $(top_builddir)/src/, $(glib_enum_h))
+ $(addprefix $(srcdir)/,$(libappindicator_headers))
-AppIndicator-0.1.gir: libappindicator.la $(glib_enum_h)
+AppIndicator-0.1.gir: libappindicator.la
AppIndicator_0_1_gir_INCLUDES = \
GObject-2.0 \
Gtk-2.0