aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-01-30 11:06:26 +0000
committerTarmac <Unknown>2013-01-30 11:06:26 +0000
commitbd333ad26f451f27f0d412f8a42f42459377bd7c (patch)
tree88817c7c7f21fc3c63395767e9c42acd588eefef /tests/Makefile.am
parentee33a9adfc9c657c3be11a8bcaf25e687fdde026 (diff)
parent3e9b3f1cd28e9c9e1263796297f5d648a163be9e (diff)
downloadlibayatana-appindicator-bd333ad26f451f27f0d412f8a42f42459377bd7c.tar.gz
libayatana-appindicator-bd333ad26f451f27f0d412f8a42f42459377bd7c.tar.bz2
libayatana-appindicator-bd333ad26f451f27f0d412f8a42f42459377bd7c.zip
This is a continuation of ~mathieu-tl/libappindicator/fix-test-merge/ which adds fixes for bug #1102589, bug #1102595, bug #1109128, and bug #1103087, which should get it finally passing CI. Fixes: https://bugs.launchpad.net/bugs/1102589, https://bugs.launchpad.net/bugs/1102595, https://bugs.launchpad.net/bugs/1103087, https://bugs.launchpad.net/bugs/1109128.
Approved by Ted Gould, PS Jenkins bot.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a65f320..3a1ecaf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -137,6 +137,8 @@ test_libappindicator_fallback_item_LDADD = \
test-libappindicator-fallback: test-libappindicator-fallback-watcher test-libappindicator-fallback-item Makefile.am
@echo "#!/bin/bash" > $@
+ @echo export DISPLAY= >> $@
+ @echo killall at-spi2-registryd >> $@
@echo . $(srcdir)/run-xvfb.sh >> $@
@echo $(DBUS_RUNNER) --task ./test-libappindicator-fallback-watcher --task-name Watcher --ignore-return --task ./test-libappindicator-fallback-item --task-name Item >> $@
@chmod +x $@
@@ -152,6 +154,8 @@ HTML_REPORT = libappindicator-check-results.html
libappindicator-tests: libappindicator-tests-gtester Makefile.am
@echo "#!/bin/bash" > $@
+ @echo export DISPLAY= >> $@
+ @echo killall at-spi2-registryd >> $@
@echo . $(srcdir)/run-xvfb.sh >> $@
@echo export UBUNTU_MENUPROXY= >> $@
@echo $(DBUS_RUNNER) --task ./libappindicator-tests-gtester >> $@
@@ -166,10 +170,12 @@ TESTS += libappindicator-tests
DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT) libappindicator-tests-gtester
-DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+DBUS_RUNNER=dbus-test-runner -m 300 --dbus-config /usr/share/dbus-test-runner/session.conf
test-libappindicator-dbus: test-libappindicator-dbus-client test-libappindicator-dbus-server Makefile.am
@echo "#!/bin/bash" > test-libappindicator-dbus
+ @echo export DISPLAY= >> $@
+ @echo killall at-spi2-registryd >> $@
@echo . $(srcdir)/run-xvfb.sh >> $@
@echo $(DBUS_RUNNER) --task ./test-libappindicator-dbus-client --task-name Client --task ./test-libappindicator-dbus-server --task-name Server --ignore-return >> test-libappindicator-dbus
@chmod +x test-libappindicator-dbus
@@ -179,6 +185,8 @@ XFAIL_TESTS = test-libappindicator-dbus
test-libappindicator-status: test-libappindicator-status-client test-libappindicator-status-server Makefile.am
@echo "#!/bin/bash" > test-libappindicator-status
+ @echo export DISPLAY= >> $@
+ @echo killall at-spi2-registryd >> $@
@echo . $(srcdir)/run-xvfb.sh >> $@
@echo $(DBUS_RUNNER) --task ./test-libappindicator-status-client --task-name Client --task ./test-libappindicator-status-server --task-name Server --ignore-return >> test-libappindicator-status
@chmod +x test-libappindicator-status