aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cee2f3..ba99ea2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,14 @@ endif()
find_package(PkgConfig REQUIRED)
pkg_check_modules(PROJECT_DEPS REQUIRED ${DEPS})
+if (ENABLE_GTKDOC)
+ find_program (GTKDOC "gtk-doc")
+ if (NOT GTKDOC_FOUND)
+ message(WARNING "Building the gtk-doc API documentation is enabled, but the gtk-doc executable has not been found. Disabling API documentation building, although requested.")
+ set (ENABLE_GTKDOC OFF)
+ endif()
+endif()
+
# Set global variables
include(GNUInstallDirs)