aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cee2f3..e869439 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,6 @@ elseif (FLAVOUR_GTK2)
)
endif()
-
if(ENABLE_TESTS)
set(DEPS ${DEPS} dbus-1>=1.12 dbus-glib-1>=0.82)
endif()
@@ -66,6 +65,14 @@ endif()
find_package(PkgConfig REQUIRED)
pkg_check_modules(PROJECT_DEPS REQUIRED ${DEPS})
+if (ENABLE_GTKDOC)
+ find_program (GTKDOC "gtk-doc")
+ if (NOT GTKDOC_FOUND)
+ message(WARNING "Building the gtk-doc API documentation is enabled, but the gtk-doc executable has not been found. Disabling API documentation building, although requested.")
+ set (ENABLE_GTKDOC OFF)
+ endif()
+endif()
+
# Set global variables
include(GNUInstallDirs)