aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index c47ed8c..8ad670f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -64,8 +64,8 @@ override_dh_install:
override_dh_auto_test: $(FLAVORS:%=dotest-%)
dotest-%:
- mkdir -p $(CURDIR)/debian/tmphome
- export HOME=$(CURDIR)/debian/tmphome && dh_auto_test --builddirectory=build/$* -- || true
+ mkdir -p $(CURDIR)/debian/tmphome/.cache
+ export HOME=$(CURDIR)/debian/tmphome && export XDG_CACHE_HOME=$(CURDIR)/debian/tmphome/.cache && dh_auto_test --builddirectory=build/$* -- || true
# View test's log file for better debugging of problems when built in clean chroots.
if [ -e build/$*/tests/test-suite.log ]; then cat build/$*/tests/test-suite.log; fi
rm -Rf $(CURDIR)/debian/tmphome