aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am63
1 files changed, 0 insertions, 63 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
deleted file mode 100644
index 0509e3e..0000000
--- a/example/Makefile.am
+++ /dev/null
@@ -1,63 +0,0 @@
-if USE_GTK3
-VER=3
-else
-VER=
-endif
-
-CLEANFILES =
-DISTCLEANFILES = Makefile Makefile.in .deps/
-EXTRA_DIST =
-
-check_PROGRAMS = \
- simple-client \
- simple-client-vala
-
-#########################################
-## simple-client
-#########################################
-
-simple_client_SOURCES = \
- simple-client.c
-
-#-Werror removed for Vala
-simple_client_CFLAGS = \
- $(LIBRARY_CFLAGS) \
- -DLOCAL_ICON="\"$(abs_srcdir)/simple-client-test-icon.png\"" \
- -Wall \
- -I$(top_srcdir)/src
-
-simple_client_LDADD = \
- $(LIBRARY_LIBS) \
- $(top_builddir)/src/libayatana-appindicator$(VER).la
-
-EXTRA_DIST += \
- simple-client-test-icon.png
-
-#########################################
-## simple-client-vala
-#########################################
-if HAVE_VALAC
-
-VALAFLAGS = \
- --pkg appindicator$(VER)-0.1 \
- --vapidir=$(top_builddir)/bindings/vala
-
-BUILT_SOURCES = simple-client-vala.c
-simple-client-vala.c: $(srcdir)/simple-client-vala.vala
- $(VALAC) $(VALAFLAGS) -C $< -o $@
- $(SED) -i "s|#include\s*<\s*libayatana-appindicator/app-indicator.h\s*>||g" $@
-
-simple_client_vala_SOURCES = simple-client-vala.c
-simple_client_vala_CFLAGS = \
- $(simple_client_CFLAGS) \
- -include $(top_srcdir)/src/app-indicator.h
-
-simple_client_vala_LDADD = $(simple_client_LDADD)
-
-CLEANFILES += *.stamp *-vala.c
-
-endif
-
-EXTRA_DIST += \
- simple-client-vala.vala
-