aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
committerMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
commit3cc2c952f3ec6d93649328a550f3ec5d10b238e2 (patch)
tree50dd30cb7ab1061ce45abd406656d82da537d8a2 /CMakeLists.txt
downloadlibayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.gz
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.bz2
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.zip
Inital commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..bf34c7c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,40 @@
+project (libayatana-common C CXX)
+cmake_minimum_required (VERSION 2.8.9)
+
+set(PROJECT_VERSION "0.8.1")
+set(PACKAGE ${CMAKE_PROJECT_NAME})
+
+# Options
+option(DISABLE_TESTS "Disable tests" off)
+
+# GNU standard installation directories
+include (GNUInstallDirs)
+set (CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
+set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
+
+# Check for prerequisites
+find_package (PkgConfig REQUIRED)
+include (FindPkgConfig)
+
+pkg_check_modules(GLIB REQUIRED
+ glib-2.0>=2.36
+)
+include_directories (${GLIB_INCLUDE_DIRS})
+
+pkg_check_modules(
+ URLDISPATCHER
+ url-dispatcher-1>=1
+)
+include_directories(${URLDISPATCHER_INCLUDE_DIRS})
+
+set(CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")
+
+add_subdirectory(src)
+
+if (DISABLE_TESTS)
+ message(STATUS "Tests disabled")
+else()
+ include(CTest)
+ enable_testing()
+ add_subdirectory(tests)
+endif()