aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 15:15:52 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 15:33:05 +0100
commit470a6533147ad3c0cab5e0b7ba99736d52a0978a (patch)
treeea3015e122c5b730bc388de8ffcda4f05a662587 /CMakeLists.txt
parentb6670f0fbf84ef7aaa74422dc3d0897c555196ee (diff)
downloadlibayatana-common-470a6533147ad3c0cab5e0b7ba99736d52a0978a.tar.gz
libayatana-common-470a6533147ad3c0cab5e0b7ba99736d52a0978a.tar.bz2
libayatana-common-470a6533147ad3c0cab5e0b7ba99736d52a0978a.zip
Explicitly set ABI_VERSION / API_VERSION and use ABI_VERSION in the .so filename.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf34c7c..0a52550 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,9 @@ cmake_minimum_required (VERSION 2.8.9)
set(PROJECT_VERSION "0.8.1")
set(PACKAGE ${CMAKE_PROJECT_NAME})
+set(API_VERSION 0)
+set(ABI_VERSION 0)
+
# Options
option(DISABLE_TESTS "Disable tests" off)