aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-06-14 23:08:17 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-16 08:26:44 +0200
commit9be11d94c663ea66cd41a9364a78531537ae405e (patch)
tree51f125b8c5b0560b1ed44668591f6cf3f7b7e5f0 /CMakeLists.txt
parentdb18ded6c8a4ab9d4a0921a3f52e8f3507607238 (diff)
downloadlibayatana-common-9be11d94c663ea66cd41a9364a78531537ae405e.tar.gz
libayatana-common-9be11d94c663ea66cd41a9364a78531537ae405e.tar.bz2
libayatana-common-9be11d94c663ea66cd41a9364a78531537ae405e.zip
Add ability to ellipsize dynamic menu item lengths.
Plus making the maximum length of non-ellipsized strings configurable via GSettings. - data/org.ayatana.common.gschema.xml.in: Add file. - data/CMakeLists.txt: Add file. - CMakeLists.txt: Add gio-2.0 dependency + 'data' build folder. - src/utils.*: Add ayatana_common_utils_elipsize function + include glib-object.h and gio.h - tests/tst_utils.cpp: Add StringFunctionsTest. - tests/CMakeLists.txt: Add GLIB_LIBRARIES to target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7430e86..f2b4b50 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,7 @@ include (FindPkgConfig)
pkg_check_modules(GLIB REQUIRED
glib-2.0>=2.36
+ gio-2.0>=2.36
)
include_directories (${GLIB_INCLUDE_DIRS})
@@ -46,6 +47,7 @@ include_directories(${URLDISPATCHER_INCLUDE_DIRS})
set(CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")
add_subdirectory(src)
+add_subdirectory(data)
if (ENABLE_TESTS)
include(CTest)