aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-26 07:33:21 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-26 07:33:21 +0200
commitb32fac907b6e61f0f94d28d0e44d77bf0883c8e2 (patch)
treec32ed6a4be5b03d5e5bccd8f7c510cac278a8854 /CMakeLists.txt
parent7f9519e1b54d4e864f2573583945419ef56f8a05 (diff)
parentc7320dab38cb2dda29226eab2c8705b5a132ac87 (diff)
downloadlibayatana-common-b32fac907b6e61f0f94d28d0e44d77bf0883c8e2.tar.gz
libayatana-common-b32fac907b6e61f0f94d28d0e44d77bf0883c8e2.tar.bz2
libayatana-common-b32fac907b6e61f0f94d28d0e44d77bf0883c8e2.zip
Merge branch 'tari01-pr/add-vala-bindings'
Attributes GH PR #35: https://github.com/AyatanaIndicators/libayatana-common/pull/35
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d72cae2..751bf36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,8 @@
project (libayatana-common C CXX)
cmake_minimum_required(VERSION 3.13)
+set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake" "${CMAKE_MODULE_PATH}")
+
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "..." FORCE)
endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
@@ -63,7 +65,7 @@ if (ENABLE_TESTS)
find_package(CoverageReport)
ENABLE_COVERAGE_REPORT(
TARGETS "ayatana-common"
- TESTS "tst_utils"
+ TESTS "tst_utils" "tst_utils_vala"
FILTER /usr/include ${CMAKE_BINARY_DIR}/*
)
endif()