aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 13:57:09 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 15:33:05 +0100
commit2e291cb027ca77a706ad4fbe4e3e0b73fa7dceda (patch)
tree4824da51670b1b34ea10d250d3778739383bb980 /debian/rules
parentb462fd7eb13c6827b9892db2a238af5af7e42a24 (diff)
downloadlibayatana-common-2e291cb027ca77a706ad4fbe4e3e0b73fa7dceda.tar.gz
libayatana-common-2e291cb027ca77a706ad4fbe4e3e0b73fa7dceda.tar.bz2
libayatana-common-2e291cb027ca77a706ad4fbe4e3e0b73fa7dceda.zip
debian/: Initial packaging draft.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f447c58
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+NULL=
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -DCMAKE_INSTALL_DIR=/usr \
+ $(NULL)
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..