aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-10-02 16:51:12 +0200
committerRobert Tari <robert@tari.in>2023-10-02 16:51:12 +0200
commit254ae9a5ef7d893f725456f5e25f9ec245acba5b (patch)
treeed4e6048094317753e920dbe1f56822961cef082 /src/CMakeLists.txt
parent6b6c2f9c7d92a7a505f1a54407590af0a329998e (diff)
downloadlibayatana-common-254ae9a5ef7d893f725456f5e25f9ec245acba5b.tar.gz
libayatana-common-254ae9a5ef7d893f725456f5e25f9ec245acba5b.tar.bz2
libayatana-common-254ae9a5ef7d893f725456f5e25f9ec245acba5b.zip
Add an execute_command with warning
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ee44f7a..c7d351d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,6 +7,8 @@ target_link_libraries(ayatana-common
${DEPS_LIBRARIES}
)
+target_compile_definitions (ayatana-common PUBLIC GETTEXT_PACKAGE="${GETTEXT_PACKAGE}" LOCALEDIR="${CMAKE_INSTALL_FULL_LOCALEDIR}")
+
if(ENABLE_LOMIRI_FEATURES)
add_definitions( -DLOMIRI_FEATURES_ENABLED )
endif()