aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
committerMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
commit3cc2c952f3ec6d93649328a550f3ec5d10b238e2 (patch)
tree50dd30cb7ab1061ce45abd406656d82da537d8a2 /src/CMakeLists.txt
downloadlibayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.gz
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.bz2
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.zip
Inital commit
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..5dce006
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+add_library(ayatana-common SHARED
+ utils.c
+)
+
+target_link_libraries(ayatana-common
+ ${GLIB_LIBRARIES}
+ ${URLDISPATCHER_LIBRARIES}
+)
+
+if(URLDISPATCHER_FOUND)
+ add_definitions( -DHAS_URLDISPATCHER )
+endif()
+
+set(PUBLIC_HEADERS
+ utils.h
+)
+
+configure_file(libayatana-common.pc.in ${CMAKE_CURRENT_BINARY_DIR}/libayatana-common.pc @ONLY)
+
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libayatana-common.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+install(FILES ${PUBLIC_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ayatana/common)
+install(TARGETS ayatana-common DESTINATION ${CMAKE_INSTALL_LIBDIR})