aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
committerMarius Gripsgard <marius@ubports.com>2021-01-12 12:18:03 +0100
commit3cc2c952f3ec6d93649328a550f3ec5d10b238e2 (patch)
tree50dd30cb7ab1061ce45abd406656d82da537d8a2 /tests/CMakeLists.txt
downloadlibayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.gz
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.tar.bz2
libayatana-common-3cc2c952f3ec6d93649328a550f3ec5d10b238e2.zip
Inital commit
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..d4c068c
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,14 @@
+find_package(GMock)
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/src
+)
+
+add_executable(tst_utils tst_utils.cpp)
+target_link_libraries(tst_utils
+ ayatana-common
+
+ ${GTEST_LIBRARIES}
+ ${GTEST_BOTH_LIBRARIES}
+)
+add_test(TstUtils tst_utils)