aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 751bf36..4dfc038 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,10 @@ pkg_check_modules(
)
include_directories(${URLDISPATCHER_INCLUDE_DIRS})
+# for GIR and Vala bindings
+find_package (GObjectIntrospection QUIET)
+find_package (Vala QUIET)
+
set(CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")
add_subdirectory(src)
@@ -76,3 +80,14 @@ endif()
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")
+
+if (INTROSPECTION_FOUND)
+ message(STATUS "Build GObjectIntrospection: YES")
+ if (VALA_COMPILER)
+ message(STATUS "Build Vala bindings: YES")
+ else()
+ message(STATUS "Build Vala bindings: NO")
+ endif()
+else()
+ message(STATUS "Build GObjectIntrospection: NO")
+endif() \ No newline at end of file