aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-10-22 11:38:37 +0200
committerRobert Tari <robert@tari.in>2021-10-22 11:38:37 +0200
commitc9063c6b37ce788a68a73498599dbaa2af9eff20 (patch)
tree440e55e613efd69b0a4727a264d300a689df6025 /CMakeLists.txt
parent99649c51f2c197c1223a204aa9c30b3f6b9c930d (diff)
parentc15189facd577c1fd3d3bf22b30bffe313b3078c (diff)
downloadlibayatana-indicator-c9063c6b37ce788a68a73498599dbaa2af9eff20.tar.gz
libayatana-indicator-c9063c6b37ce788a68a73498599dbaa2af9eff20.tar.bz2
libayatana-indicator-c9063c6b37ce788a68a73498599dbaa2af9eff20.zip
Merge branch 'sunweaver-pr/gtk2-flavour-build-fix'
Attributes GH PR #57: https://github.com/AyatanaIndicators/libayatana-indicator/pull/57
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b92a3c..cfd3bfc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,10 +40,21 @@ endif()
set(DEPS
glib-2.0>=2.37
- gtk+-3.0>=3.24
gmodule-2.0
gio-unix-2.0
)
+if (FLAVOUR_GTK3)
+ set(DEPS
+ ${DEPS}
+ gtk+-3.0>=3.24
+ )
+endif()
+if (FLAVOUR_GTK2)
+ set(DEPS
+ ${DEPS}
+ gtk+-2.0>=2.18
+ )
+endif()
if (FLAVOUR_GTK3 AND ENABLE_IDO)
set(DEPS