aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-12 13:27:15 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-12 17:09:30 +0200
commitbfb679de31ba276e0155153fc3efff9b8aacbbf6 (patch)
tree958e56a9a100d74a01022764f199a0bf96c38f59 /data/CMakeLists.txt
parentc7a152ad3da254704945de297f0de957966fb6b8 (diff)
downloadlibayatana-indicator-bfb679de31ba276e0155153fc3efff9b8aacbbf6.tar.gz
libayatana-indicator-bfb679de31ba276e0155153fc3efff9b8aacbbf6.tar.bz2
libayatana-indicator-bfb679de31ba276e0155153fc3efff9b8aacbbf6.zip
Bring back GTK+-2.0 and GTK+-3.0 build flavours.
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt26
1 files changed, 20 insertions, 6 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index f6c71d9..8e10313 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -1,12 +1,26 @@
# ayatana-indicator3-0.4.pc
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator3-0.4.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.4.pc" @ONLY)
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.4.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+if (FLAVOUR_GTK3)
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator3.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.${API_VERSION}.pc" @ONLY)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+else()
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" @ONLY)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+endif()
+
+# ayatana-indicators.target (only required once, so let's do it with FLAVOUR_GTK3)
+
+if (FLAVOUR_GTK3)
-# ayatana-indicators.target
+ pkg_check_modules(SYSTEMD systemd)
-pkg_check_modules(SYSTEMD systemd)
+ if (${SYSTEMD_FOUND})
+ if (${SYSTEMD_VERSION} VERSION_LESS 247)
+ set(SYSTEMD_USER_UNIT_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/user)
+ else()
+ pkg_get_variable(SYSTEMD_USER_UNIT_DIR systemd systemd_user_unit_dir)
+ endif()
+ install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicators.target" DESTINATION "${SYSTEMD_USER_UNIT_DIR}")
+ endif()
-if (${SYSTEMD_FOUND})
- install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicators.target" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/systemd/user")
endif()