aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2008-11-24 22:32:57 -0600
committerTed Gould <ted@canonical.com>2008-11-24 22:32:57 -0600
commitf45883312746b395935a3756fe04abe1459a8dd8 (patch)
treebab7fcea762f817754d0621683260e0cb90e079d /data/icons/Makefile.am
parente23753e30197f082671295a8a0db60a871c0edd1 (diff)
downloadlibayatana-indicator-f45883312746b395935a3756fe04abe1459a8dd8.tar.gz
libayatana-indicator-f45883312746b395935a3756fe04abe1459a8dd8.tar.bz2
libayatana-indicator-f45883312746b395935a3756fe04abe1459a8dd8.zip
Adding in the infrastructure to have icons in the build. Only a dummy icon for now, but it's there and ready for some friends.
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..17dca13
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = scalable 16x16 22x22 24x24 32x32 48x48
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(pkgdatadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+