aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorEvgeni Golov <evgeni@debian.org>2010-06-16 09:50:48 +0200
committerEvgeni Golov <evgeni@debian.org>2010-06-16 09:50:48 +0200
commit30f1ae42f91519b8f06660c8c352a5fefb301c4b (patch)
tree1637676094d80fb3569d6ace6eeb39d6fecf5b97 /debian/rules
parentec36577978bd7e31c0f52083d5d9d05976edc2db (diff)
downloadlibayatana-indicator-0.3.8-1.tar.gz
libayatana-indicator-0.3.8-1.tar.bz2
libayatana-indicator-0.3.8-1.zip
Apply 0.3.8-1 changes0.3.8-1
* Merge Ubuntu package into Debian. Closes: #549999 * debian/copyright: + Update to machine readable format. * debian/control: + Drop cdbs Build-Dep, bump debhelper to >=7. + Standards-Version 3.8.4. + Update Vcs-* fields. + Drop GNOME from Description, the package is not GNOME specific. + Slightly update Description, thanks lintian. * debian/rules: + Use minimal debhelper 7 rules without cdbs. + Disable tests for now, they fail (launchpad 587811) * debian/source/format: + Add file, make package 3.0 (quilt).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 9 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 151c78d..9612514 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,14 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-DEB_DH_MAKESHLIBS_ARGS_libindicator0 += -V 'libindicator0 (>= 0.3.6)'
+%:
+ dh $@
+
+override_dh_auto_test:
+
+override_dh_makeshlibs:
+ dh_makeshlibs -V 'libindicator0 (>= 0.3.6)'