aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIain Lane <iain.lane@canonical.com>2013-02-22 10:34:24 +0000
committerIain Lane <iain.lane@canonical.com>2013-02-22 10:34:24 +0000
commit31368ce8e47efe5d754d007ec71b610f6c6c4f76 (patch)
treea22f6286aaea7e168e5f7b4910c3d1f99a8df320 /debian/rules
parent150610dc58dce0e4a7461d30e62775ebd2728b8f (diff)
downloadlibayatana-indicator-31368ce8e47efe5d754d007ec71b610f6c6c4f76.tar.gz
libayatana-indicator-31368ce8e47efe5d754d007ec71b610f6c6c4f76.tar.bz2
libayatana-indicator-31368ce8e47efe5d754d007ec71b610f6c6c4f76.zip
Disable silent rules for more useful build logs
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ec764bb..26be5f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
FLAVORS = gtk2 gtk3
+COMMON_CONFIGURE_FLAGS = --disable-silent-rules
+
CONFIGURE_FLAGS_gtk2 = --with-gtk=2
CONFIGURE_FLAGS_gtk3 = --with-gtk=3
@@ -19,7 +21,7 @@ override_dh_autoreconf:
override_dh_auto_configure: $(FLAVORS:%=doconfigure-%)
doconfigure-%:
- DH_VERBOSE=1 dh_auto_configure --builddirectory=builddir/$* -- $(CONFIGURE_FLAGS_$*)
+ DH_VERBOSE=1 dh_auto_configure --builddirectory=builddir/$* -- --disable-silent-rules $(CONFIGURE_FLAGS_$*)
override_dh_auto_build: $(FLAVORS:%=dobuild-%)