aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-05-14 17:25:41 +0200
committerRobert Tari <robert@tari.in>2021-05-14 17:25:41 +0200
commit763acdea57d43c9a5dd063879a050c76b72c26dc (patch)
tree0dfc1c8c031490d2f3ad3d0605ac0e764b669e42 /debian/rules
parent025c376068f63d8c2aa5899a3c0b1b827370da28 (diff)
parent173f104d15f5bd7478eed303c43e8426fb6d67a8 (diff)
downloadlibayatana-indicator-763acdea57d43c9a5dd063879a050c76b72c26dc.tar.gz
libayatana-indicator-763acdea57d43c9a5dd063879a050c76b72c26dc.tar.bz2
libayatana-indicator-763acdea57d43c9a5dd063879a050c76b72c26dc.zip
Merge branch 'sunweaver-pr/bring-back-gtk2-builds'
Attributes GH PR #44: https://github.com/AyatanaIndicators/libayatana-indicator/pull/44
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 7 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 3082a13..300730b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,10 +6,10 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-COMMON_CONFIGURE_FLAGS = --disable-silent-rules
+COMMON_CONFIGURE_FLAGS = -DENABLE_TESTS=ON
-CONFIGURE_FLAGS_gtk2 = --with-gtk=2
-CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+CONFIGURE_FLAGS_gtk2 = -DFLAVOUR_GTK2=ON -DFLAVOUR_GTK3=OFF
+CONFIGURE_FLAGS_gtk3 = -DFLAVOUR_GTK3=ON -DFLAVOUR_GTK2=OFF
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -17,10 +17,7 @@ export G_MESSAGES_DEBUG = all
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
%:
- dh $@ --with autoreconf
-
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+ dh $@
override_dh_auto_configure: $(FLAVORS:%=doconfigure-%)
@@ -32,10 +29,9 @@ override_dh_auto_build: $(FLAVORS:%=dobuild-%)
dobuild-%:
dh_auto_build --builddirectory=builddir/$*
-override_dh_auto_test: $(FLAVORS:%=dotest-%)
-
-dotest-%:
- dh_auto_test --no-parallel --builddirectory=builddir/$*
+override_dh_auto_test:
+ xvfb-run -a dh_auto_test --no-parallel --builddirectory=builddir/gtk2
+ xvfb-run -a dh_auto_test --no-parallel --builddirectory=builddir/gtk3
override_dh_auto_install: $(FLAVORS:%=doinstall-%)