aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-07-07 10:11:32 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-07-07 10:11:32 -0400
commit95d709f429490ec4d3a636b8cf0747ceedbbc995 (patch)
treee6e64ca83555d0074177a386bb9e604f6fda4915 /debian/rules
parent36fb97c7c97c3b40b48190e8e37b494bdff9edb9 (diff)
parent8677620e7825d0ac249f5bc71210e4cf5dab53ec (diff)
downloadlibayatana-indicator-95d709f429490ec4d3a636b8cf0747ceedbbc995.tar.gz
libayatana-indicator-95d709f429490ec4d3a636b8cf0747ceedbbc995.tar.bz2
libayatana-indicator-95d709f429490ec4d3a636b8cf0747ceedbbc995.zip
* New upstream release.
* Build Fixes * Adding license to test files (LP: #684886) * Bump API/ABI versions appropriately and make easier to edit them in the future * Adding a name-hint to the indicator entries * Merging scroll functions into a single good one (LP: #804618) * debian/*install, control: Changing ABI version number bump in package names * debian/rules: Making GTK2 the special case as GTK3 is default now * debian/*install: Fixing pkgconfig file names
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules40
1 files changed, 20 insertions, 20 deletions
diff --git a/debian/rules b/debian/rules
index 4c21f86..4581c33 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,31 +9,31 @@ DEB_BUILDDIR = $(DEB_SRCDIR)/build
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-DEB_DH_MAKESHLIBS_ARGS_libindicator3 += -V 'libindicator3 (>= 0.3.19)'
-DEB_DH_MAKESHLIBS_ARGS_libindicator3_3 += -V 'libindicator3-3 (>= 0.3.19)'
+DEB_DH_MAKESHLIBS_ARGS_libindicator4 += -V 'libindicator4 (>= 0.3.90)'
+DEB_DH_MAKESHLIBS_ARGS_libindicator3_4 += -V 'libindicator3-4 (>= 0.3.90)'
-configure/libindicator3-3:: stamp-configure-gtk3
-stamp-configure-gtk3:
- : # configure for GTK+ 3.0
+configure/libindicator4:: stamp-configure-gtk2
+stamp-configure-gtk2:
+ : # configure for GTK+ 2.0
set -e; \
- rm -rf build-gtk3; \
- mkdir build-gtk3; \
- cd build-gtk3; \
- $(DEB_CONFIGURE_SCRIPT_ENV) ../configure --with-gtk=3 \
+ rm -rf build-gtk2; \
+ mkdir build-gtk2; \
+ cd build-gtk2; \
+ $(DEB_CONFIGURE_SCRIPT_ENV) ../configure --with-gtk=2 \
$(filter-out --srcdir=%, $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)); \
cd ..;
- touch stamp-configure-gtk3
+ touch stamp-configure-gtk2
-build/libindicator3-3:: stamp-build-gtk3
-stamp-build-gtk3: stamp-configure-gtk3
- : # build for GTK+ 3.0
- $(MAKE) -C build-gtk3;
- touch stamp-build-gtk3
+build/libindicator4:: stamp-build-gtk2
+stamp-build-gtk2: stamp-configure-gtk2
+ : # build for GTK+ 2.0
+ $(MAKE) -C build-gtk2;
+ touch stamp-build-gtk2
-common-install-prehook-arch:: stamp-build-gtk3
- : # install for GTK+ 3.0
- $(MAKE) -C build-gtk3 DESTDIR=$(CURDIR)/debian/tmp install
+common-install-prehook-arch:: stamp-build-gtk2
+ : # install for GTK+ 2.0
+ $(MAKE) -C build-gtk2 DESTDIR=$(CURDIR)/debian/tmp install
clean::
- rm -f stamp-*-gtk3
- rm -rf build-gtk3
+ rm -f stamp-*-gtk2
+ rm -rf build-gtk2