aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2010-02-04 19:00:38 -0800
committerSebastien Bacher <seb128@ubuntu.com>2010-02-04 19:00:38 -0800
commit050ef48d22ce3f4626eb11867fea14f0e8a0854e (patch)
treeed69171d22fa26aa06fd91feefacef1f9fd69974 /tests/Makefile.am
parent717a085c50ac2e0b93ca9c79fdcf954eb9e253f6 (diff)
parent72ef75fa51c63e533ff2883bffc75bfc86a2c521 (diff)
downloadlibayatana-indicator-0.3.2-0ubuntu1.tar.gz
libayatana-indicator-0.3.2-0ubuntu1.tar.bz2
libayatana-indicator-0.3.2-0ubuntu1.zip
releasing version 0.3.2-0ubuntu10.3.2-0ubuntu1
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fcccb6..b111655 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,9 @@ lib_LTLIBRARIES = \
libdummy-indicator-simple.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+
+EXTRA_DIST = run-xvfb.sh
#############################
# Test Loader
@@ -297,7 +300,8 @@ XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
- @echo "#!/bin/sh" > loader-tester
+ @echo "#!/bin/bash" > loader-tester
+ @echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
@chmod +x loader-tester