aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-19 10:41:20 -0600
committerTed Gould <ted@gould.cx>2012-01-19 10:41:20 -0600
commit1cf6a9761db8beefc8d2a73c2cf9903264424c66 (patch)
tree8e358aa08f9e32aa8b6b8b9580ed615b4f99642d /tests/Makefile.am
parente3ce5513c45374858d9af5ae82ff9a711b6cf2aa (diff)
parent6a0f41aaa53cb79e03520a8214cc2c9305821496 (diff)
downloadlibayatana-indicator-1cf6a9761db8beefc8d2a73c2cf9903264424c66.tar.gz
libayatana-indicator-1cf6a9761db8beefc8d2a73c2cf9903264424c66.tar.bz2
libayatana-indicator-1cf6a9761db8beefc8d2a73c2cf9903264424c66.zip
Adding a window ID function to pass the window ID
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f11a9d1..c8a9ba7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,8 @@ lib_LTLIBRARIES = \
libdummy-indicator-blank.la \
libdummy-indicator-null.la \
libdummy-indicator-signaler.la \
- libdummy-indicator-simple.la
+ libdummy-indicator-simple.la \
+ libdummy-indicator-entry-func.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
@@ -162,6 +163,27 @@ libdummy_indicator_simple_la_LDFLAGS = \
-avoid-version
#############################
+# Dummy Indicator Entry Func
+#############################
+
+libdummy_indicator_entry_func_la_SOURCES = \
+ dummy-indicator-entry-func.c \
+ dummy-indicator-entry-func.h
+
+libdummy_indicator_entry_func_la_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+libdummy_indicator_entry_func_la_LIBADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ $(INDICATOR_LIB)
+
+libdummy_indicator_entry_func_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+#############################
# Service Shutdown Timeout
#############################
@@ -412,7 +434,7 @@ DISTCLEANFILES += service-manager-connect-nostart-tester
XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
-loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
+loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la libdummy-indicator-entry-func.la Makefile
@echo "#!/bin/bash" > loader-tester
@echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester