aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-12-04 11:22:11 +0100
committerRobert Tari <robert@tari.in>2020-12-04 11:22:11 +0100
commit1f54cb3fc971a8121497819d7bc03b1f6c736963 (patch)
tree7bd7033f90db469583e761dfe3b5991e6df3d7fd /tests/Makefile.am
parent4489b124930e00aaedb020f6b9a38f64535ecdb9 (diff)
parent1a62e1e531ae4ebe133964dcf788185fd33f51c9 (diff)
downloadlibayatana-indicator-1f54cb3fc971a8121497819d7bc03b1f6c736963.tar.gz
libayatana-indicator-1f54cb3fc971a8121497819d7bc03b1f6c736963.tar.bz2
libayatana-indicator-1f54cb3fc971a8121497819d7bc03b1f6c736963.zip
Merge branch 'sunweaver-pr/fix-test-indicator-ng'
Attributes GH PR #32: https://github.com/AyatanaIndicators/libayatana-indicator/pull/32
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3d7ea3b..87430f6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -499,8 +499,20 @@ test_indicator_ng_LDADD = \
-L$(top_builddir)/libayatana-indicator/.libs \
$(INDICATOR_LIB)
-TESTS += test-indicator-ng
-DISTCLEANFILES += test-indicator-ng
+
+test-indicator-ng-dbus-runner: test-indicator-ng Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo $(DBUS_RUNNER) --task ./test-indicator-ng >> $@
+ @chmod +x $@
+
+test-indicator-ng-tester: test-indicator-ng-dbus-runner Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-indicator-ng-dbus-runner >> $@
+ @chmod +x $@
+
+TESTS += test-indicator-ng-tester
+DISTCLEANFILES += test-indicator-ng-tester test-indicator-ng-dbus-runner test-indicator-ng
# Mock indicator service
check_PROGRAMS += indicator-test-service