aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-20 12:36:07 -0500
committerTed Gould <ted@canonical.com>2009-04-20 12:36:07 -0500
commit38c6ce2a36d6416016f64e5963deee29bc02f8b3 (patch)
treea0a91d4bc623b5d23713efcad65518ee2bf4beb1 /tests/Makefile.am
parent443c83ab353b818227270aa63f655fb2cbdbeba7 (diff)
downloadlibayatana-indicator-38c6ce2a36d6416016f64e5963deee29bc02f8b3.tar.gz
libayatana-indicator-38c6ce2a36d6416016f64e5963deee29bc02f8b3.tar.bz2
libayatana-indicator-38c6ce2a36d6416016f64e5963deee29bc02f8b3.zip
Adding an interests test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 36818b8..256a699 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,11 @@
TESTS = \
- test_simple
+ test_simple \
+ test_interests
libexec_PROGRAMS = \
+ test-interests-client \
+ test-interests-server \
test-simple-client \
test-simple-server
@@ -31,3 +34,25 @@ test_simple_server_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
+test_interests: test-interests-client test-interests-server
+
+test_interests_client_SOURCES = \
+ test-interests-client.c
+
+test_interests_client_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_client_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_interests_server_SOURCES = \
+ test-interests-server.c
+
+test_interests_server_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+