aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-16 15:24:51 -0600
committerTed Gould <ted@gould.cx>2010-02-16 15:24:51 -0600
commit53c9f60b7438764853c54d977a37b267bdf64485 (patch)
treecfe75f26927c40a449ad8d34fa3e324a92a68e02 /tests/Makefile.am
parent1a85eb2ce73907d4f9b11a05efbc3f5c2c77e82a (diff)
downloadlibayatana-indicator-53c9f60b7438764853c54d977a37b267bdf64485.tar.gz
libayatana-indicator-53c9f60b7438764853c54d977a37b267bdf64485.tar.bz2
libayatana-indicator-53c9f60b7438764853c54d977a37b267bdf64485.zip
Adding in a basic test desktop file test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b111655..ab776a9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,6 +34,41 @@ test_loader_LDADD = \
-lindicator
#############################
+# Test Desktop Shortcuts
+#############################
+
+check_PROGRAMS += test-desktop-shortcuts
+
+test_desktop_shortcuts_SOURCES = \
+ test-desktop-shortcuts.c
+
+test_desktop_shortcuts_CFLAGS = \
+ -Wall -Werror \
+ -DSRCDIR="\"$(srcdir)\"" \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+test_desktop_shortcuts_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+
+DS_XML_REPORT = desktop-shortcuts-check-results.xml
+DS_HTML_REPORT = desktop-shortcuts-check-results.html
+
+test-desktop-shortcuts-tester: test-desktop-shortcuts Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-desktop-shortcuts >> $@
+ @chmod +x $@
+
+TESTS += test-desktop-shortcuts-tester
+DISTCLEANFILES += test-desktop-shortcuts-tester \
+ $(DS_XML_REPORT)
+ $(DS_HTML_REPORT)
+
+
+#############################
# Dummy Indicator Blank
#############################