aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-13 16:38:58 +0100
committerTed Gould <ted@gould.cx>2012-01-13 16:38:58 +0100
commit68c166698b604451b1f14280c14838d4461121b2 (patch)
tree31b39b1e08e766f92ac7dbda21bff36087fcd15a /tests/Makefile.am
parent0419bac431d9820e3e611aeb2d95f3a6d2caf258 (diff)
downloadlibayatana-indicator-68c166698b604451b1f14280c14838d4461121b2.tar.gz
libayatana-indicator-68c166698b604451b1f14280c14838d4461121b2.tar.bz2
libayatana-indicator-68c166698b604451b1f14280c14838d4461121b2.zip
Build a new dummy indicator
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f11a9d1..9d16748 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,8 @@ lib_LTLIBRARIES = \
libdummy-indicator-blank.la \
libdummy-indicator-null.la \
libdummy-indicator-signaler.la \
- libdummy-indicator-simple.la
+ libdummy-indicator-simple.la \
+ libdummy-indicator-entry-func.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
@@ -162,6 +163,26 @@ libdummy_indicator_simple_la_LDFLAGS = \
-avoid-version
#############################
+# Dummy Indicator Entry Func
+#############################
+
+libdummy_indicator_entry_func_la_SOURCES = \
+ dummy-indicator-entry-func.c
+
+libdummy_indicator_entry_func_la_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+libdummy_indicator_entry_func_la_LIBADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ $(INDICATOR_LIB)
+
+libdummy_indicator_entry_func_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+#############################
# Service Shutdown Timeout
#############################