aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-04 10:55:48 -0600
committerTed Gould <ted@canonical.com>2009-11-04 10:55:48 -0600
commit8033011194d1063ca6cb16ec99e00e6ade2fcc42 (patch)
treef5dfa7c9d856300a6233f4577694e59b341bf419 /tests/Makefile.am
parentdb2a2391c759a2b8a17f4c661cc7e62e6c1d1495 (diff)
downloadlibayatana-indicator-8033011194d1063ca6cb16ec99e00e6ade2fcc42.tar.gz
libayatana-indicator-8033011194d1063ca6cb16ec99e00e6ade2fcc42.tar.bz2
libayatana-indicator-8033011194d1063ca6cb16ec99e00e6ade2fcc42.zip
Building a dummy indicator that signals.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 656d53e..6150449 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,6 +5,7 @@ check_PROGRAMS = \
lib_LTLIBRARIES = \
libdummy-indicator-blank.la \
libdummy-indicator-null.la \
+ libdummy-indicator-signaler.la \
libdummy-indicator-simple.la
#############################
@@ -65,6 +66,26 @@ libdummy_indicator_null_la_LDFLAGS = \
-avoid-version
#############################
+# Dummy Indicator Signaler
+#############################
+
+libdummy_indicator_signaler_la_SOURCES = \
+ dummy-indicator-signaler.c
+
+libdummy_indicator_signaler_la_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+libdummy_indicator_signaler_la_LIBADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+
+libdummy_indicator_signaler_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+#############################
# Dummy Indicator Simple
#############################