aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-01-16 12:47:51 -0600
committerTed Gould <ted@canonical.com>2009-01-16 12:47:51 -0600
commit8f801277df211416ca9636b3d28ead43f9f50a35 (patch)
tree9ba348e8bdd89ecaec99fe600641673e44eff206 /tests/Makefile.am
parent487239d3df7362f7f5ec5d4934a8672787f557e7 (diff)
downloadlibayatana-indicator-8f801277df211416ca9636b3d28ead43f9f50a35.tar.gz
libayatana-indicator-8f801277df211416ca9636b3d28ead43f9f50a35.tar.bz2
libayatana-indicator-8f801277df211416ca9636b3d28ead43f9f50a35.zip
Moving the tests so that they can guarantee to build after the library
builds as otherwise they end up getting built first.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..03ec716
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,38 @@
+
+noinst_PROGRAMS = \
+ indicate-and-crash \
+ indicate-alot \
+ listen-and-print
+
+indicate_and_crash_SOURCES = \
+ indicate-and-crash.c
+
+indicate_and_crash_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(LIBINDICATE_CFLAGS)
+
+indicate_and_crash_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+indicate_alot_SOURCES = \
+ indicate-alot.c
+
+indicate_alot_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(LIBINDICATE_CFLAGS)
+
+indicate_alot_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+listen_and_print_SOURCES = \
+ listen-and-print.c
+
+listen_and_print_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(LIBINDICATE_CFLAGS)
+
+listen_and_print_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)