aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-02 12:01:22 -0800
committerTed Gould <ted@gould.cx>2010-02-02 12:01:22 -0800
commit953e656562c2178a21880fc6cd5e43788994872a (patch)
tree506512ddfac3cf85e7224b8aaa681ee9a4c3769a /tests/Makefile.am
parent103f8b0b79cfaf3e90e4ea01987485155b450d03 (diff)
downloadlibayatana-indicator-953e656562c2178a21880fc6cd5e43788994872a.tar.gz
libayatana-indicator-953e656562c2178a21880fc6cd5e43788994872a.tar.bz2
libayatana-indicator-953e656562c2178a21880fc6cd5e43788994872a.zip
Adding in run-xvfb.sh
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fcccb6..97b3919 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,9 @@ lib_LTLIBRARIES = \
libdummy-indicator-simple.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+
+EXTRA_DIST = run-xvfb.sh
#############################
# Test Loader
@@ -298,6 +301,7 @@ HTML_REPORT = loader-check-results.html
loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
@echo "#!/bin/sh" > loader-tester
+ @echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
@chmod +x loader-tester