aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-01-21 17:34:44 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-01-21 17:34:44 +0100
commitd84d6f7cce3715ec88a67418c4d4298237618463 (patch)
tree9df8e7f13176748b6270e4060af476d109869561 /tests/Makefile.am
parent36e0fea77699a71d03245900b9c0ae5a7cf2bcf5 (diff)
downloadlibayatana-indicator-d84d6f7cce3715ec88a67418c4d4298237618463.tar.gz
libayatana-indicator-d84d6f7cce3715ec88a67418c4d4298237618463.tar.bz2
libayatana-indicator-d84d6f7cce3715ec88a67418c4d4298237618463.zip
Add basic tests for indicator-ng
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c98bdbf..97741b0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -466,3 +466,28 @@ DISTCLEANFILES += loader-tester
DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT)
+#############################
+# Indicator-ng
+#############################
+
+if USE_GTK3
+
+check_PROGRAMS += test-indicator-ng
+
+test_indicator_ng_SOURCES = test-indicator-ng.c
+
+test_indicator_ng_CFLAGS = \
+ $(LIBINDICATOR_CFLAGS) \
+ -I$(top_srcdir) \
+ -DSRCDIR="\"$(srcdir)\"" \
+ -Wall
+
+test_indicator_ng_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ $(INDICATOR_LIB)
+
+TESTS += test-indicator-ng
+DISTCLEANFILES = test-indicator-ng
+
+endif