aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-20 14:44:25 -0500
committerTed Gould <ted@canonical.com>2009-04-20 14:44:25 -0500
commitecad1e36dce18875461e76d2a47d8a0e11570ff6 (patch)
tree1194e137bb35005c88e97fc2aabf5b1a1356b9ef /tests/Makefile.am
parentc5cc32d7fa7c6abe909f3d19a7e1deb529bcc4a9 (diff)
downloadlibayatana-indicator-ecad1e36dce18875461e76d2a47d8a0e11570ff6.tar.gz
libayatana-indicator-ecad1e36dce18875461e76d2a47d8a0e11570ff6.tar.bz2
libayatana-indicator-ecad1e36dce18875461e76d2a47d8a0e11570ff6.zip
Adding in multiple servers connecting in to declare interest test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am60
1 files changed, 59 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 256a699..6117bee 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,11 +1,17 @@
TESTS = \
test_simple \
- test_interests
+ test_interests \
+ test_interests_multi
libexec_PROGRAMS = \
test-interests-client \
test-interests-server \
+ test-interests-server1 \
+ test-interests-server2 \
+ test-interests-server3 \
+ test-interests-server4 \
+ test-interests-server5 \
test-simple-client \
test-simple-server
@@ -56,3 +62,55 @@ test_interests_server_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
+test_interests_multi: test-interests-client test-interests-server1 test-interests-server2 test-interests-server3 test-interests-server4 test-interests-server5
+
+test_interests_server1_SOURCES = \
+ test-interests-server1.c
+
+test_interests_server1_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server1_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_interests_server2_SOURCES = \
+ test-interests-server2.c
+
+test_interests_server2_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server2_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_interests_server3_SOURCES = \
+ test-interests-server3.c
+
+test_interests_server3_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server3_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_interests_server4_SOURCES = \
+ test-interests-server4.c
+
+test_interests_server4_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server4_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_interests_server5_SOURCES = \
+ test-interests-server5.c
+
+test_interests_server5_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_interests_server5_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+