aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-20 10:57:57 -0500
committerTed Gould <ted@canonical.com>2009-04-20 10:57:57 -0500
commitecfb1c26cdb0908e552a33ccad288f3224038f97 (patch)
tree12de2459abedcbb09f914a472942dfe3888ef2f2 /tests/Makefile.am
parenta1ccd1a94e3b2ec2c7ce60c5b6b8824a2bf04076 (diff)
downloadlibayatana-indicator-ecfb1c26cdb0908e552a33ccad288f3224038f97.tar.gz
libayatana-indicator-ecfb1c26cdb0908e552a33ccad288f3224038f97.tar.bz2
libayatana-indicator-ecfb1c26cdb0908e552a33ccad288f3224038f97.zip
Build infrastructure for first test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..8f290f9
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,29 @@
+
+DBUS_RUNNER=/home/ted/Development/dbus-fun/dbus-test-runner --dbus-config /home/ted/Development/dbus-fun/session.conf
+
+TESTS = \
+ test_simple
+
+test_simple: test_simple_c test_simple_s
+ $(DBUS_RUNNER) --task ./test_simple_c --task-name Client --task ./test_simple_s --task-name Server
+
+test_simple_c_SOURCES = \
+ test-simple-c.c
+
+test_simple_c_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_simple_c_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_simple_s_SOURCES = \
+ test-simple-s.c
+
+test_simple_s_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_simple_s_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+