aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-29 11:34:44 -0500
committerTed Gould <ted@canonical.com>2009-10-29 11:34:44 -0500
commitfc573dc11ca279d7a6aaf3c5164fb6e772f8d37c (patch)
treebe51c51cb42bded5f93de281ef6208e836273182 /tests/Makefile.am
parentec0809ed60a94f582ad7111a992fa0f60e493016 (diff)
downloadlibayatana-indicator-fc573dc11ca279d7a6aaf3c5164fb6e772f8d37c.tar.gz
libayatana-indicator-fc573dc11ca279d7a6aaf3c5164fb6e772f8d37c.tar.bz2
libayatana-indicator-fc573dc11ca279d7a6aaf3c5164fb6e772f8d37c.zip
Creating a new test and linking it into things.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8121136..fc83186 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,7 @@
check_PROGRAMS = \
- test-loader
+ test-loader \
+ service-shutdown-timeout
lib_LTLIBRARIES = \
libdummy-indicator-blank.la \
@@ -77,6 +78,21 @@ libdummy_indicator_simple_la_LDFLAGS = \
-avoid-version
#############################
+# Service Shutdown Timeout
+#############################
+
+service_shutdown_timeout_SOURCES = \
+ service-shutdown-timeout.c
+
+service_shutdown_timeout_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+service_shutdown_timeout_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ $(top_builddir)/libindicator/.libs/libindicator.a
+
+#############################
# Test stuff
#############################