aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-11-24 10:04:28 -0600
committerTed Gould <ted@gould.cx>2009-11-24 10:04:28 -0600
commit93650be784700d574f25eb28114784d88d767ced (patch)
treeaa0597ba2e3835259ac8486d0de30eef1a194e20 /tools/Makefile.am
parenta7b77875edb12a6ef46e58b6f26324d25c10b7cd (diff)
downloadlibayatana-indicator-93650be784700d574f25eb28114784d88d767ced.tar.gz
libayatana-indicator-93650be784700d574f25eb28114784d88d767ced.tar.bz2
libayatana-indicator-93650be784700d574f25eb28114784d88d767ced.zip
Adding a small little tool to load an indicator from the command line.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9de44fc..5e5ef8d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1 +1,21 @@
-#Something
+
+libexec_PROGRAMS = \
+ indicator-loader
+
+#############################
+# Indicator Loader
+#############################
+
+indicator_loader_SOURCES = \
+ indicator-loader.c
+
+indicator_loader_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+indicator_loader_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+