aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-11-24 16:33:38 -0600
committerTed Gould <ted@gould.cx>2009-11-24 16:33:38 -0600
commitad2ef4d35017d674caecc65ccde4e500b0740982 (patch)
treed78f66b1fd9e9f73f6573810ed62950c39914a07 /tools/Makefile.am
parenta7b77875edb12a6ef46e58b6f26324d25c10b7cd (diff)
parentbfb7a29cb4e8de7ac9bd8376ecdedfded0cbcac0 (diff)
downloadlibayatana-indicator-ad2ef4d35017d674caecc65ccde4e500b0740982.tar.gz
libayatana-indicator-ad2ef4d35017d674caecc65ccde4e500b0740982.tar.bz2
libayatana-indicator-ad2ef4d35017d674caecc65ccde4e500b0740982.zip
Adding in a small tool to test loading of indicators on the command line. (easier development)
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9de44fc..5e5ef8d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1 +1,21 @@
-#Something
+
+libexec_PROGRAMS = \
+ indicator-loader
+
+#############################
+# Indicator Loader
+#############################
+
+indicator_loader_SOURCES = \
+ indicator-loader.c
+
+indicator_loader_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+indicator_loader_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+