aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 20 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b92a3c..8af6ff5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,8 +19,13 @@ else()
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
# Check for prerequisites
@@ -40,10 +45,21 @@ endif()
set(DEPS
glib-2.0>=2.37
- gtk+-3.0>=3.24
gmodule-2.0
gio-unix-2.0
)
+if (FLAVOUR_GTK3)
+ set(DEPS
+ ${DEPS}
+ gtk+-3.0>=3.24
+ )
+endif()
+if (FLAVOUR_GTK2)
+ set(DEPS
+ ${DEPS}
+ gtk+-2.0>=2.18
+ )
+endif()
if (FLAVOUR_GTK3 AND ENABLE_IDO)
set(DEPS
@@ -67,21 +83,9 @@ endif (HAVE_LIB_M)
include(GNUInstallDirs)
set(ABI_VERSION "7")
set(API_VERSION "4")
-set(PROJECT_VERSION "0.8.4")
+set(PROJECT_VERSION "0.9.4")
set(PROJECT_NAME "libayatana-indicator")
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
-
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Weverything")
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-c++98-compat -Wno-padded")
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-documentation")
-
-else()
-
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wall")
-
-endif()
-
# Make everything
add_subdirectory(src)