aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23350c6..ba47820 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_INIT(libindicator, 0.3.11, ted@canonical.com)
+AC_INIT(libindicator, 0.3.12, ted@canonical.com)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(libindicator, 0.3.11)
+AM_INIT_AUTOMAKE(libindicator, 0.3.12)
AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES])
@@ -84,6 +84,20 @@ AC_DEFINE_PATH(PREFIX, "${prefix}", [prefix directory])
AC_DEFINE_PATH(SYSCONFDIR, "${sysconfdir}", [system configuration dir])
AC_DEFINE_PATH(LIBDIR, "${libdir}", [system configuration dir])
+#########################
+# Debug symbols
+#########################
+AC_ARG_ENABLE([debug],
+ AC_HELP_STRING([--enable-debug], [build with debug symbols]),,
+ [enable_debug=no])
+
+if test "x$enable_debug" = "xyes"; then
+ CFLAGS="-g $CFLAGS"
+ AC_DEFINE(ENABLE_DEBUG, 1, [build with extra debug information])
+fi
+
+AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
+
###########################
# Files
###########################
@@ -105,4 +119,6 @@ AC_MSG_NOTICE([
Libindicator Configuration:
Prefix: $prefix
+
+ Enable debugging: $enable_debug
])