aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2357f13..4710901 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,14 @@ AC_DEFINE_PATH(SYSCONFDIR, "${sysconfdir}", [system configuration dir])
AC_DEFINE_PATH(LIBDIR, "${libdir}", [system configuration dir])
#########################
+# Check if build tests
+#########################
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [disable tests]),,
+ [enable_tests=yes])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
+#########################
# Debug symbols
#########################
AC_ARG_ENABLE([debug],
@@ -122,6 +130,15 @@ fi
AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -146,5 +163,7 @@ Libindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
+ Enable tests: $enable_tests
Enable debugging: $enable_debug
+ Coverage reporting: $use_gcov
])