aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 4932f07..94cf3e0 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -47,6 +47,11 @@ libindicator_la_CFLAGS = \
libindicator_la_LIBADD = \
$(LIBINDICATOR_LIBS)
+libindicator_la_LDFLAGS = \
+ -version-info 1:0:0 \
+ -no-undefined \
+ -export-symbols-regex "^[^_].*"
+
# We duplicate these here because Automake won't let us use $(VER) on the left hand side.
# Since we carefully use $(VER) in the right hand side above, we can assign the same values.
# Only one version of the library is every compiled at the same time, so it is safe to reuse
@@ -56,6 +61,7 @@ libindicator3include_HEADERS = $(indicator_headers)
libindicator3_la_SOURCES = $(libindicator_la_SOURCES)
libindicator3_la_CFLAGS = $(libindicator_la_CFLAGS)
libindicator3_la_LIBADD = $(libindicator_la_LIBADD)
+libindicator3_la_LDFLAGS = $(libindicator_la_LDFLAGS)
pkgconfig_DATA = indicator$(VER).pc
pkgconfigdir = $(libdir)/pkgconfig