aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c21ff09..8121136 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,6 +3,7 @@ check_PROGRAMS = \
test-loader
lib_LTLIBRARIES = \
+ libdummy-indicator-blank.la \
libdummy-indicator-null.la \
libdummy-indicator-simple.la
@@ -22,6 +23,24 @@ test_loader_LDADD = \
$(LIBINDICATOR_LIBS) $(top_builddir)/libindicator/.libs/libindicator.a
#############################
+# Dummy Indicator Blank
+#############################
+
+libdummy_indicator_blank_la_SOURCES = \
+ dummy-indicator-blank.c
+
+libdummy_indicator_blank_la_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+libdummy_indicator_blank_la_LIBADD = \
+ $(LIBINDICATOR_LIBS)
+
+libdummy_indicator_blank_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+#############################
# Dummy Indicator NULL
#############################