aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-21 11:42:28 -0500
committerTed Gould <ted@gould.cx>2010-09-21 11:42:28 -0500
commit56b4d9a181b29082051ed9c0e4743eca52eac52f (patch)
tree3102a3ee520f0275539c1ebfa7a924d85da434fe /Makefile.am
parent6c3c66e1ccbe10364cb04a7bf1816001bb2fe560 (diff)
downloadlibdbusmenu-56b4d9a181b29082051ed9c0e4743eca52eac52f.tar.gz
libdbusmenu-56b4d9a181b29082051ed9c0e4743eca52eac52f.tar.bz2
libdbusmenu-56b4d9a181b29082051ed9c0e4743eca52eac52f.zip
Adding in ChangeLog and AUTHORS dist-hooks
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3853d2a..b5fff3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,3 +12,29 @@ SUBDIRS = \
po
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi