aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDidier Roche <didier.roche@canonical.com>2010-09-22 14:55:39 +0200
committerDidier Roche <didier.roche@canonical.com>2010-09-22 14:55:39 +0200
commitfd9a7d175a4d6b17d04803245b30e547d34af9dc (patch)
tree5a44e627bce214448a63fc08d4933d631d7971f6 /Makefile.am
parent199c1c21538a1618aaec22be54a32b15f291067e (diff)
parent9cc32d2064b803d005b1e0824022528a295c8fdd (diff)
downloadlibdbusmenu-fd9a7d175a4d6b17d04803245b30e547d34af9dc.tar.gz
libdbusmenu-fd9a7d175a4d6b17d04803245b30e547d34af9dc.tar.bz2
libdbusmenu-fd9a7d175a4d6b17d04803245b30e547d34af9dc.zip
Import upstream version 0.3.15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3853d2a..b5fff3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,3 +12,29 @@ SUBDIRS = \
po
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi